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Distributor  
MapInfo Corporation  
One Global View  
Troy, New York 12180  
Tel: 518-285-6000 or 800-FASTMAP  
Fax: 518-285-6070  
http://www.mapinfo.com  

System Requirements  
Microsoft Windows 98, 2000, Windows NT 4.0 and Windows XP  
32 Mb of RAM  
Minimum of a Pentium processor  
16 or 24-bit SVGA monitor recommended  

Introduction  
MapInfo Professional version 7.0 is the latest release by MapInfo Corporation of their 
desktop GIS software product. MapInfo Professional software package includes the 
installation CD, 3-D glasses for the 3-D window, and a 759 page User's Guide. The 
User's Guide and Reference Guides are also available in pdf format on the installation 
CD.  

MapInfo organizes all its information within the software in the form of tables that 
are stored with a .tab extension. For instance, if you open up an Excel spreadsheet in 
MapInfo, the software will automatically create a .tab file which describes the 
structure of the Excel data without modifying the Excel table. Tables that include 
spatial features have a .tab extension, but the graphic features are stored in a file 
with a .map extension. MapInfo can open tables from Microsoft Access and Excel, 
dBase, delimited ASCII, Lotus1-2-3, ESRI shapefiles, and Raster and Grid images. 
Tables remain open in Mapinfo until you close the table from using the File-Close 
Table menu. Mapinfo stores the configuration of the open tables and windows into a 
workspace file (.wor).  
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MapInfo Professional Windows  
MapInfo Professional has six major types of windows that can be open:  

• Map windows are used to display geographic objects from a table.  
• Legend windows can be created with a Legend wizard to represent a 

cartographic legend of the layers in a Map window.  
• Browser windows show tabular data associated with a layer in the Map 

window or tables from conventional databases.  
• Graph windows present information as graphs to make comparisons of 

numeric data.  
• Layout windows are a page layout feature that allows you to combine your 

Map, Browser, Legend and Graph windows on a page for presentation quality 
output.  

• Redistricting windows group map objects into districts in order to perform 
aggregate calculations on the data to provide totals of net values for the 
districts.  

 
Figure 1: MapInfo User interface with a Map window, Browser window and 

Layout window open 

Users can create new windows or navigate to open windows using the Window menu. 
Windows can be closed by pressing the x (close) button on the upper right of an 
open window, but you should note that this deletes the window from your 
workspace. The user interface is basically the same for the different windows. You 
will get a specific menu item for the particular window that you have active. For 
instance, you'll see a Map menu when a Map window is active and a Browse menu 
when a Browser window is open. The tools and buttons remain the same for each 
window, but they will be grayed out if they can't function in a particular window.  

Tools  
There are five toolbars that are included with the software:  



• The Standard toolbar contains tools for commonly performed menu functions 
from the File, Edit and Window menu.  

• The Main toolbar contains tools to select objects, change the views in the Map 
window, get information about an object, and to measure distances.  

• The Drawing toolbar contains tools and commands that are used to create 
and edit map objects.  

• The Tools toolbar has tools for working with MapBasic and buttons that 
display when the tools are loaded.  

• The DBMS toolbar contains tools that are used to access tables residing on 
remote databases.  

MapInfo contains a Tool manager under the Tools menu that allows users to load 
specific tools onto the Tools toolbar and the Tools menu. Users that write MapBasic 
programs to enhance the functionality of MapInfo can run their MapBasic programs 
using the Run MapBasic Program option under the Tools menu or by pressing the 
button on the Tools toolbar. MapBasic is a scripting language for MapInfo and is sold 
as a separate product. The MapBasic window in MapInfo records user actions similar 
to recording a macro in Microsoft office products. The code can be saved as a text 
file or can be copy and pasted into a MapBasic program.  

Options  
The options menu allows the user to set default display styles for regions, lines, 
symbols and text. Users can control which toolbars are displayed and whether to 
show the Legend window, MapBasic window and Statistics window. The Preferences 
option lets users to specify their preferences for the System settings, Map window, 
Legend window, startup, Address matching, directories, output settings, printer and 
style preferences.  

Map Layers  
MapInfo Professional stores tables that contain geographic information into layers in 
the Map window using a layer control dialog box. (See Figure 2) The layer control 
dialog box can be accessed through the Map menu or by pressing the layer control 
button.  

   



Figure 2: MapInfo Layer Control Box 

The cosmetic layer is a blank transparent layer that lies on top of the other map 
layers. The cosmetic layer stores map titles and other graphic object and can be 
turned on or off similar to the other layers. The cosmetic layer is always the top map 
layer and it cannot be removed or reordered. Cosmetic objects can be saved or 
cleared using options on the Map menu.  

The first column of checkboxes in the Layer Control dialog box, under the eye icon, 
controls whether a layers can be displayed on the map by checking or unchecking 
the box next to the layer name. The second column of checkboxes under the pencil 
icon controls whether a layer is editable, only one box can be checked at a time 
making only one layer editable at a time. The third column of checkboxes under the 
arrow icon controls whether a layer is selectable for operations such as to get 
information about a map feature with the Info tool. The last column of checkboxes 
under the tag icon controls whether the labels for a layer are displayed on the map.  

The Layer control box has a series of buttons to Add or Remove layers from the Map 
Window and to reorder the layers. The Display button on the right control provides 
options to change the style of the features in a layer. The Label button allows the 
user to set the font for the labels for a layer. The thematic button changes how the 
thematic display of a layer. Thematic layers can be created using the Create 
Thematic Map option in the Map menu. Thematic layers are displayed above the 
layer they represent with the following notation with/by (ex. See Ind. value with 
District in Figure 2). The Hotlink button allows users to setup hotlinks on objects 
and/or labels for a layer.  

The Map menu also includes functionality to create 3D and Prism maps. The 3D maps 
and Prism maps will open in a stand-alone window that allows you to rotate, pan and 
zoom on the viewpoint. Users can set the projection, coordinate units, distance units 
and area units using Options in the Map menu.  
   
Editing and Drawing Features  
MapInfo provides a complete set of drawing tools and editing commands to edit 
objects on the map. If you wish to edit a specific layer, make sure that you check the 
editable box next to that layer in the Layer Control dialog box. The drawing toolbar 
has tools to draw arcs, ellipses, lines, polygons, polylines, rectangles, rounded 
rectangles, symbols and text. The drawing toolbar also has buttons for the user to 
set the style for the drawn objects and a Reshape and Add Node buttons for working 
with nodes on features. The Object menu has additional functionality to edit objects 
such as Combine, Disaggregate, Split, Erase, Smooth, Unsmooth, etc.  

Selecting Records from Tables  
MapInfo provides two methods to select records from tables. You can select records 
from the screen or you can select records using queries. To select records on the 
screen, Mapinfo provides the Select tool, Radius Select tool, Boundary Select tool, 
Polygon Select tool, Marque Select tool and the Invert Selection tool. To select 
records using queries, a user can use the Select or SQL select commands from the 
Query menu. The Select command allows you to select records based on a condition 
for a single table. The SQL Select provides the functionality of SQL that allows you to 
create queries to aggregate data, group data, order data and join multiple tables.  



Records that are selected are stored in a temporary table. You can access the 
temporary table by selecting New Browser Window from the Window menu. Once 
you close the table with the Close Table command, the temporary table is removed 
from the workspace and you will have to recreate the selection to view the selected 
records.  

Table Manipulation  
The Table menu provides the functionality to manage tables in MapInfo. Users can 
update columns with new values that the user specifies or from separate table. 
Tables that contain address information can be geocoded against a Search table or 
the user can automatically create a point layer on a map if the table has x,y 
coordinates in the table. The Table Maintenance option provides functions to modify 
the table structure, delete tables, rename table and pack tables. Modifying the table 
structure allows a user to add or delete fields from a table, and to view the data 
types associated with each field and the ability to change the data type of a field. 
The Table menu also has options to Import and Export data to and from different 
formats.  

New Functionality in version 7.0  

• Enhanced Operating System Support: MapInfo supports Windows 98 and NT 
4.0 and has been certified for Windows 2000. MapInfo has also received the 
“Designed for Windows XP” logo.  

• New and Enhanced Database Support: MapInfo supports the latest versions of 
Oracle Spatial, 9i and 9i Locator, SpatialWare® 4.6 on all its supported 
platforms, Microsoft Access 2000 and SQL Server, versions 7.0 and 2000.  

• Ease of Use Improvements: The Open Dialog box has been redesigned for 
efficient access and management of files. The Find in Front Window Only 
options allows users to perform a Query Find in only the front window.  

• File Type Support: MapInfo provides the ability to open shapefiles directly 
from the File-Open dialog box. Raster handlers are installed that support 
government agency formats, ASRP, ADRG, CADRG, CIB, and NITF, as well as 
MrSID and ECW raster handlers. MapInfo also provides the ability to import 
OSGB format GML files.  

• New and Enhanced Map Creation and Editing Objects: MapInfo can now rotate 
map features in addition to text and labels. The arrow keys on the keyboard 
will move selected objects in an editable layer. The backspace key can be 
used as a delete to undo the last node when using tools for editing polygons 
and polylines.  

• New and Enhanced Object Processing: MapInfo can create Voronoi Polygons 
for trade area or coverage area analysis. The Split by Polyline feature creates 
custom objects by splitting both closed and linear objects with a road or user-
defined line.  

• New and Enhanced Map and Layout Display Options: There is a new North 
Arrow tool that places a North Arrow with the style that the user chooses in 
the map or layout windows.  

• New and Enhanced Publishing Options: MapInfo provides a new version of 
Crystal Reports with the ability to publish to HTML, export to HTML or PDF 
and OLE2 embedding capabilities. MapInfo provides the ability for the user to 
set default preferences such as default projections, styles, DBMS connections 
and Auto Scroll. They have added or improved the following tools: Coordinate 
Extractor Tool, TOC Utility and the Universal Translator. There is also several 



new projections added, sample data improvements and additional MapBasic 
support.  

Conclusion  
I tried to structure this review to give a complete overview of the software for 
someone that has never used the product and to provide information regarding the 
latest updates for experienced MapInfo users. MapInfo Professional was the first GIS 
software program that I learned back in graduate school several years ago. The feel 
of the software and ease of use has been the same throughout the progression of 
versions that have been released since that time. MapInfo Professional continues to 
upgrade its software product to reflect changes in the operating system and 
database system environments, while adding new tools and functionality to improve 
the product.  
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